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O Macromedia © Dreamweaver é uma poderosa ferramenta para criação de páginas de Internet, 
hoje na versão 7 (MX2004) na minha opinião o melhor programa WYSIWYG (what you see is what 
you get) aquilo que vemos é aquilo que fazemos. 
O cada vez mais exigente mundo da multimédia que envolve a Internet fez com que a equipa do 
Dreamweaver dotasse o programa das mais variadas ferramentas que se interligam com as 
diferentes linguagens de programação (ASP, PHP, XML, JSP, Cold Fusion, etc.) e com as mais 
diversificadas ferramentas dinâmicas e de animação. 
O Dreamweaver MX e MX 2004 tem a facilidade de se integrar com outros aplicações da 
Macromedia como o Flash e o Shockwave. 
Com o Dreameweaver podemos criar sites para a Web, graças à sua interface gráfica de fácil 
utilização que mostra as modificações à medida que são efetuadas. Além disso, teremos a certeza 
de que o  código HTML gerado nos é consistentemente limpo, conciso e perfeitamente editável, ao 
contrário do que acontece com a maioria maioria dos programas de edição visual para criação da 
Web, o Dreamweaver não altera o código HTML quando importa documentos de um outro 
programa HTML. 
 

Paulo Barbosa da Silva © 2004 
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1. Considerações Gerais 
 
O Macromedia Dreamweaver tem evoluído qualitativamente desde a versão 3. A cada nova versão, 
implementações importantes são incorporadas e, muitas delas, sabidamente adicionadas,  
devido à "wish list", colocada à disposição dos utilizadores pela Macromedia para este produto. 
 

 
Versão 2 

 
 

 
Versão 3 
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Versão 4 

 
Neste manual vou falar das últimas duas versões do programa. A versão 6.0 ou Mx e a versão 7.0 
ou MX 2004. 
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1.1. Requisitos do sistema 
 
Intel Pentium III ou superior 
Windows 98, 2000 ou XP 
256 Mb Ram (mínimo), recomendado 512 Mb  
800 Mb espaço disponível em disco. 
 
1.2. A quem se destina este manual 
 
Este manual destina-se a todos os webdesigners e programadores de Internet que queiram 
começar a utilizar o Dreamweaver, ou mesmo para quem já trabalha com o programa, facilitando, 
no meu entender a aprendizagem do mesmo. 
 
Pretendo dar a conhecer as principais funcionalidades deste magnífico editor de páginas de 
Internet de uma forma simples e de fácil compreensão. 
 
Embora eu explique os principais recursos deste programa, há muito mais disponível para 
descobrir. 
 
2. Visão Geral 
 
O Dreamweaver pode ser usado tanto por quem sabe, como por quem não sabe nada de HTML. Na 
construção de sites apenas nos podemos guiar pelo conjunto de ferramentas disponíveis, no 
entanto, e uma vez que convém saber o básico de HTML, o Dreamweaver facilita a aprendisagem 
do mesmo porque podemos editar no layout ao mesmo tempo que vemos a inserção/alteração no 
código. 
  
Para que se torne mais fácil a compreensão do Dreamweaver é importante conhecer, em primeiro 
lugar, toda a configuração e distribuição da área de trabalho. 
 
Na imagem seguinte pode-se ver a área de trabalho e barras de ferramentas que explicarei, agora 
numa abordagem geral, e mais adiante detalhadamente por temas, para melhor os especificar. 
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Barras de Ferramentas 
 
Ferramentas de inserção (Insert) – esta é uma das principais barras de ferramentas uma vez que é 
nela que estão as principais ferramentas (e básicas) para a criação do layout de um site. 
 

 
 
 

A versão MX 2004, ou 7, dá-nos a possibilidade de criar ou personalizar a nossa própria barra de 
ferramentas. Basta clicar com o botão direito do mouse sobre a barra e escolher Customize 
Favorites… 
 
 
Painel de Propriedades – neste painel encontram-se as propriedades da página e dos vários 
elementos inseridos na mesma. Consoante o objecto seleccionado o painel de propriedades 
apresentará as suas características. 
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Visualização do código fonte: 
 

 
 
Design: vista do layout, ou design da página; 
Code: vista do código da página; 
Split: vista conjunta do código fonte e do layout da página; 
Live Data View: simulação da visão no browser. 
 
Painel inspector de código: 
 

 

Neste painel, dividido em camadas ficam localizados os 
inspectores do código fonte. São nestes inspectores que são 
criados os elementos dinâmicos como CSS, Behaviors, 
Snnipets, ligação a bases de dados e muitos outros. 
Os painéis podem ser arrastados para outros locais do 
espaço de trabalho. 

 

 
 
 
Site Map 
 
Permite a visualização de toda a estrutura do site em forma de “àrvore” tornando assim mais fácil 
o acesso a qualquer arquivo de uma forma fácil. Os links são actualizados automaticamente. 
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O Code Inspector ou inspector de HTML é totalmente integrado com o editor WYSIWYG. As 
alterações feitas no layout aparecem automaticamente no código. 
 
Para aceder ao inspector HTML, na tecla F10 ou menu Window > HTML. 
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Para melhor orientação também se pode seguir pelo rodapé do espaço de trabalho as respectivas 
tags onde o cursor estiver localizado. 
 

 
Tag inspector 
 
 
3. Personalização do Dreamweaver 
 
Todos trabalhamos de maneira diferente. Para melhor adaptar o Dreamweaver às nossas 
necessidades e métodos de trabalho, podemos personaliza-lo da melhor forma. Para isso acedemos 
ao painel Properties (propriedades) no menu Edit > Preferences (Ctrl + U). 
 
 

 
 
Este é o painel das Preferences (ou preferências). Do lado esquerdo estão as categorias e do lado 
direito os aspectos que poderão ser modificados, acrescentados ou retirados. Várias opções já vêm 
activadas por defeito que poderão ser alteradas posteriormente. 
Passo a descrever algumas das principais categorias. 
 
3.1. General 
 
Update links when Opening Read-Only Files é uma opção importante para actualização dos links: 
 
Prompt - alerta sobre o link alterado. Para redirecioná-lo clique em update e para não o 
redirecionar, clique em don`t update; 
Always - o Dreamweaver automaticamente redireciona os links alterados sem precisar de 
confirmação; 
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Never - o Dreamweaver ignorará as alterações de links, tendo assim, que ser feito o 
redireccionamento manualmente. (Aconselho o uso da opção prompt ou always). 
 

 

Para mudar a visualização do espaço de 
trabalho basta accionar o botão Change 
Workspace… e escolher entre a visualização 
Designer e Coder na versão 7 (2004), ou na 
versão 6 entre a visualização do MX e da 
versão 4, esta mais “arrumada”, uma vez 
que apenas estão visíveis as barras de 
ferramentas que estamos a utilizar. 
 
Tudo depende do método de trabalho de 
cada um. 

 

 
 
Para quem trabalha com muitos textos a opção Allow multiple consecutive spaces é muito útil. Por 
defeito no Dreamweaver só se consegue dar um espaço entre as palavras. Para dar mais que um 
espaço temos duas hipótses: ou vamos ao código fonte e acrescentamos um &nbsp; ou então, 
muito mais cómodo, activamos esta opção. 
 
Outra opção útil é o Maximum number of history steps permite definir o numero de vezes que 
podmos voltar atrá nas acções, o Undo (Ctrl + Z). Este valor pode ir de 2 a 99999. 
 

 

No Insert Panel pode-se definir a visão da barra de 
ferramentas Insert. Se queremos que sejam visualizados os 
ícones – Ícones Only, apenas texto Text Only, ou ambos – 
Icons and Text. 

 
 
3.2. Accessibility 
 
Ao activar estes atributos, serão mostrados os mesmos automaticamente na inserção de 
formulários, frames, vídeo ou áudio, imagens e tabelas. 
 
Por exemplo na inserção de uma imagem aparece uma caixa de diálogo para atribuição do texto 
que aparece quando o ponteiro do rato está em cima da imagem. 
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3.3. Code Coloring 
 

 
 

Esta é uma opção muito útil não só para quem trabalha muito com o código fonte mas sobretudo 
para quem faz alterações esporádicas no mesmo uma vez que define a cor de cada código (HTML, 
Cold Fusion, ASP, PHP, etc.) tornando mais fácil a sua identificação. 
Para modificar ou atribuir uma cor ao respectivo código, basta escolher o tipo e accionar o botão 
Edit Coloring Scheme e editar os vários parâmetros. 
 
Para modificar a cor de fundo da página de código basta modificar o Default background. 
 
 
3.4. Code Hints 
 

 
 

Continuando na edição do código fonte temos aqui mais opções úteis. 
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Com Enable auto tag completion marcado, aparecerá uma pequena janela (tipo pop-up) com uma 
lista de códigos possíveis ao escrever o primeiro carácter e que pode ser completado 
automaticamente, bastando para isso escolher na lista e dar enter. 
Para que este “auto-completar” apareça, a opção Enable Code Hints terá que estar marcada. 
Em baixo destas duas opções temos uma linha de tempo que corresponde ao espaço de segundos 
que a lista de códigos demorará a aparecer. 
 
Em Menus temos o tipo de código possível a aparecer nesta lista de opções do mesmo. 
 
 
3.5. Code Rewriting 
 
Ainda  no código fonte, o Code Rewriting personaliza a escrita do mesmo. 
 

 
 
Em Rewrite code podemos escolher tags fixas inválidas; Renomear um form quando se copia, 
remove ou se cola uma tag extra; ou remove uma tag quando se fecha o código. 
 
Em Never rewrite code define-se que tipo de arquivo o Dreamweaver pode ou não reescrever um 
código. 
 
Para quem trabalha com programação no Dreamweaver a opção Spetial characters é muito 
importante uma vez que activa a opção de subtituição de caracteres de um endereço por símbolos 
“&”. Ao activar estas opções convem ter algum conhecimento de programação uma vez que é 
alterado o código da página e por vezes poderam deixar de funcionar alguns elementos. 
 
3.6. File Type/Editors 
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O  tipo de arquivos que serão abertos em modo de visualização de código definem-se nesta 
categoria – Open in Code View – e pode ainda definir um editor externo do mesmo código, caso 
esteja a ser utilizado. 
 
Podem ainda definir-se os programas que editaram o tipo de ficheiros (de imagem, flash, media, 
etc.). Por exemplo os ficheiros .gif estão definidos, por defeito, com o Fireworks, no caso de não 
utilizar este programa poderá ser alterado para outro qualquer, como por exemplo o Photoshop ou 
o Paint Shop Pro. 
 
 
3.7. Fonts 
 
Em Fonts é possível determinar o tipo de fonte relativamente ao tipo de escrita de caracteres, 
Europeu, Japonês, Árabe, etc., e o tipo de letra utilizada como opção principal no layout e no 
código da página. 
 
As fontes padrão disponibilizadas pelo Dreamweaver, são o Arial, Helvetica, Times New-Roman , 
Courier New , Courier , Georgia , Times , Verdana e Geneva. No entanto podemos adicionar mais 
fontes para uso posterior. Menu Text > Font > Edit Font List. 
 
Dica: É importante saber que as fontes de texto utilizadas nas páginas de Internet deveram estar 
instaladas nos computadores dos utilizadores, para que estas sejam correctamente visualizadas, e 
evitar discrepâncias no tipo de fonte utilizada. Por isto é conveniente utilizar as fontes de texto 
padrão instaladas com o Windows. São elas o Arial, Helvetica, Times New-Roman , Courier New , 
Courier , Georgia , Times , Verdana e Geneva. 
No caso de utilizar-mos outro tipo de fonte de texto corre-se o risco de não ser correctamente 
vizualizada no browser, utilizando-se muitas vezes para isso uma imagem do texto (normalmente 
.gif). 
 
 
3.8. Highlighting 
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Esta é uma opção muito útil quando se utilizam alguns 
elementos e recursos como os templates ou as library. 
Aqui podem-se definir as cores por que são identificados 
estes elementos no layout facilitando assim a identificação 
dos mesmos. 
 
Em show, no caso dos elementos que aparecem no layout, 
poder-se-à optar por deixa-los ou não visíveis.  

 
3.9. Invisible Elements 
 
Alguns elementos quando inseridos na página só seram visíveis quando visualizados no browser. 
Para identificar estes elementos no layout da página é necessário que esteja essa função habilitada 
na respectiva categoria. 
 

 
 
Nesta janela podem-se activar ou desactivar acções, ou propriedades (elementos). No caso de Line 

breacks é desnecessário activar uma vez que em cada quebra de linha irá aparecer um ícone , o 
que se torna desnecessário. 
 
Na última opção activa a exibição do conteúdo de uma include – Server-Side, que explicarei mais 
adiante. 
 
3.10. Panels 
 
Nesta Janela são configuradas todas as opções relacionadas com os painéis e barras de tarefas. 
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Na primeira configuração temos o Always on Top, e como o próprio nome indica , são os painéis 
que ficaram sempre acima de tudo. Ou seja tudo o que esteja marcado ficará acima da janela 
principal. 
 
Em Icons é activada a exibição dos ícones no roda-pé da área de trabalho (layout). 

 
 

Em Show in Launcher são definidos, em  , quais os painéis que deveram aparecer por baixo da 
página principal, e em baixo a ordem dos painéis da direita. 
Estas duas últimas opções não estão disponíveis na versão 2004. 
 
3.11. Preview in Browser 
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O Preview in Browser define os browsers  com os quais o Dreamweaver vai interagir para testar a 
página, na qual estamos a trabalhar, o chamado preview. Neste caso poderemos definir o browser 
como primário ou secundário, sendo o primário, e conforme o nome indica, o principal. 
Para acrescentar um browser acciona-se o botão do +. Nele podemos testar os vários browsers 
existentes. 
 

 
 
Em Options é activado o uso de arquivos temporários para o preview. Se esta opção não estiver 
activa o Dreamweaver abrirá a página directamente do arquivo original. Para realizar o preview a 
página terá de ser gravada primeiro antes de ser testada. 
 
 
3.12. Status Bar 
 

 
 
As opções do Status Bar são de grande interesse para quem quer testar a visualização nas várias 
dimensões de ecrân e o tempo de abertura da página nas várias velocidades de modem. 
 
Em Window Sizes define-se o tamanho de ecran e em Connection Speed a velocidade em Kb do 
modem. Os resultados são visualizados no roda-pé da página principal (layout) como mostra a 
figura em baixo. 
 

 
 
 
Estas são as opções principais e mais importantes para a personalização do Dreamweaver. No 
entanto poderão experimentar as opções que não expliquei, embora algumas delas sejam já 
avançadas, não fazendo diferença numa fase de aprendizagem, e mesmo na criação de um site 
convencional (HTML). 
 
 
 
4. Configuração de um site 
 
Para ter um acesso completo a todos os recursos disponíveis no Dreamweaver, é importante 
configurar o site no mesmo. Para além de ter acesso aos recursos disponíveis teremos uma melhor 
noção das pastas e arquivos assim como as ligações (links) que fazem parte do projecto. 
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Na versão 6 - MX (ou 6.1)vamos ao menu Site 
> New Site… ou no painel do lado direito Files 
menu Site > New Site… 
 

 
 

 

 
 
Na versão 7 – MX 2004 – esta opção está no 
menu Site > Manage Sites… e aparecerá uma 
janela como a imagem ao lado, acciona-se o 
botão New… e Site. 
 
 
 
 
 

 
 
 
 
Abrir-se-à a janela de configuração do site Site Difinition for Unnamed Site 1 como mostra a 
imagem em baixo. 
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Em cima há dois separadores, o Basic e Advanced. Para quem se inicia no Dreamweaver poderá 
começar pelo básico (Basic) uma vez que é de mais fácil configuração. 
 
A seguir explicarei as duas formas. 
 
4.1. Modo Básico - Basic 
 
Na primeira janela (imagem anterior) apagamos o Unnamed Site 1, sempre colocado por defeito, e 
colocamos o nome do site que queremos configurar, e acciona-se Next>. 
 

 
 
Para quem trabalha com programação o melhor será escolher a segunda hipótese, Yes, I want to 
use… e na check box em baixo escolher o tipo de linguagem, nesta fase, como não falarei de 
programação escolhemos a primeira hipótese e Next>. 
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Agora deverá ser fornecida a informação relativa à localização do site. 
No caso de estar alojado no nosso computador deixa-mos estar como está. Se pretender-mos 
construir o site directamente no servidor escolhemos a segunda opção. 
 
Neste caso teremos o site alojado no nosso computador. 
Antes de configurar o site convém que a respectiva pasta tenha já sido criada. Clicamos no ícone 
da pasta amarela e escolhemos a respectiva localização do site. 
 
Na janela seguinte será escolhido o modo de conectar ao servidor remoto para transferência do 
site. Para já não escolheremos qualquer modo, mais adiante entraremos nesta área de FTP. Ficará 
então None. 
 
 
 
Para finalizar será mostrada na última janela o resumo de dados referente à configuração do site. È 
só accionar Done para finalizar a configuração. 
 

 
 
 
 
 
 
 
 

4.2. Modo Avançado – Advanced 
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No modo Advanced temos do lado esquerdo a categoria e do lado direito os respectivos elementos 
que a compõem. 
 
Para mais fácil compreensão começarei por explicar as categorias principais (e básicas), e mais 
tarde as restantes para melhor integração nos vários assuntos. 
 
 
Local Info 
 
Aqui, conforme a imagem em cima, é dado o nome do site, neste caso Novo Site, a localização, e 
em Default images folder podemos dar a localização da pasta que irá conter as imagens. 
 
Em HTTP adress, caso já exista, poderemos colocar o URL do site (http://www.site.com). 
 
 
Design Notes 
 
Em Design notes desmarca-se a primeira opção, uma vez que se trata de uma interligação entre o 
Dreamweaver e os programas Fireworks e Flash da Macromedia que para uma fase inicial, e para 
quem não utilize estes programas, não fará sentido utilizar. 
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Está assim configurado o site em modo Básico ou Avançado no Dreamweaver MX ou MX 2004. 
 
Dica: Para melhor organização do site, poderão ser criadas várias pastas para fácil identificação 
dos arquivos e ficheiros – uma pasta para as páginas (paginas), outra para as imagens (imagens), 
outra para folhas de estilo (css), etc.. 
 
 
 
4.3. Backup das Configurações 
 
Este recurso do Dreamweaver é muito útil e torna-se conveniente fazer quando temos vários sites 
configurados uma vez que poupará trabalho caso haja necessidade de desinstalar o Dreamweaver 
ou formatar o disco do computador. Esta tarefa evita ter de refazer todas as configurações dos 
sites existentes. 
 
Para executar esta operação, menu Site > Manage Sites… e escolhe-se Export… 
 

 

 
Esta operação criará um arquivo com extenção .ste. 

 
 
Convém guardar este ficheiro numa disquete ou outro 
tipo de suporte para no caso de se perder informação 
do disco rígido termos essa informação salvaguardada. 
 
Quando se pretender configurar o site de novo basta 
seguir os mesmos passos, e ao invés de fazer Export 
faz-se Import. 
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5. Layout 
 
 
Depois de configurado o site no Dreamweaver, podemos começar a desenhar o layout das páginas, 
ou a definir a estrutura do site. 
 
Na versão 2004, ao iniciar o Dreamweaver aparecerá, por defeito, a janela que vemos na imagem 
seguinte: 
 

 
 

Pode-se escolher o tipo de página que queremos criar, ou simplesmente abrir uma já existente, 
que ficaram visualizadas do lado esquerdo (as últimas a serem editadas). Também se pode aceder 
ao tutorial do Dreamweaver, ou ao gestor de extenções em Dreamweaver Exchange. 
 
No caso de não querer-mos voltar a visualizar este painel na abertura do programa basta colocar o 
visto em “Don’t show again”. 
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Na versão anterior o MX, versão 6,  a janela anterior não aparecerá. Para criar uma nova página 
iremos ao menu File> New … e surgirá a janela New Document (imagem de baixo). 
 

 
 

Do lado esquerdo a categoria da página e no centro o tipo de página. Para páginas em HTML, a 
escolha é Basic page e HTML. Nesta página poderá ser adicionada posteriormente scripts de 
Javascript ou folhas de estilo (CSS), entre outras. 
 
No caso de utilizar linguagem de programação será Dynamic page e a respectiva programação 
(ASP, PHP, etc.). 
 
Accionar Create e será visualizada a página em branco. 
 
Para melhor orientação das dimensões e alinhamento de objectos existem elementos qu 
poderemos visualizar como as Rules ou réguas no menu View > Rules > Show ou Ctrl + Alt + R. 
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Podemos também visualizar a “grade” que divide a página com colunas e linhas em igual distância. 
Nenu View > Grid > Show Grid ou Ctrl + Alt + G.  
 

 
 
 
5.1. Propriedades da página 
 
Depois de criada a página é conveniente definir as propriedades da mesma para que esta se ajuste 
ao tipo de layout que pretendemos criar. 
 
Para aceder às propriedades da página, na versão MX damos um clique direito algures na página e 
Page Properties …, ou no menu Modify > Page Properties … (ou Ctrl+J). 
 

 
 

Então temos: 
 
Title: Título da página (que aparecerá no browser); 
Background Image: Imagem de fundo; 
Background: Cor de fundo da página; 
Text: Cor do texto (normalmente fica sem cor, ou seja preto); 
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Links: Cor dos links; 
Visited Links: Cor dos links que já foram visitados; 
Active Links: Cor dos links quando se clica; 
Left e Top Margin: Tamanho das margens esquerda e topo respectivamente em pixels; 
Margin Width e Height: Tamanho das margens direita e em baixo; 
Document Encoding: Tipo de carácter (país); 
Tracing Image: Imagem que aparecerá em fundo no modo de design. Esta imagem apenas 
aparecerá no dreamweaver. Muitas vezes serve para seguir um desenho pré-definido do site. 
Image Transparency: Transparência ou opacidade da imagem de fundo (Tracing image). 
 
A versão 2004 tem disponível no painel de propriedades um botão que acede às propriedades da 
página, no entanto, tal como na versão anterior, também se pode aceder às mesmas com um 
clique direito do rato algures na página. 
 

 
 
Nota: O clique direito na página para aceder às propriedades desta não pode ser dado dentro de 
uma tabela, pois aparecerá Properties referente às propriedades da tabela, que normalmente já 
estarão visíveis. 
 

 
 

Na nova versão aparecem novas características, que passo a descrever. As restantes são iguais à 
versão MX. 
 
Appearance 
 
Right e Bottom margin: margem direita e rodapé da página que convém não marcar uma vez que 
limita de alguma forma a dimensão da página; 
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Links 
 

 
 
Underline style: Define se o sublinhado do link aparece ou não, se aparece ou desaparce apenas 
quando o ponteiro do rato passa por cima. 
 
 
Headings: Definição dos títulos. Tipo e tamanho da letra. 
 
5.2. Inserção de elementos na página 
 
5.2.1. Barras de Ferramentas 
 
A seguir identificarei todos os ícones das barras de tarefas, embora explique mais adiante 
detalhadamente as funções de alguns mais complexos. 
 
As imagens que se seguem são referentes à versão MX2004. Na versão MX os ícones são iguais 
apenas poderão, alguns deles, estar em diferentes barras, mas de fácil identificação. 
 
Common 
 
Esta barra de ferramentas contém os elementos mais usuais numa página, imagens, tabelas, links, 
etc. 
 

 
 

 Links- Insere uma hiperligação para uma página interna ou externa ao site; 

 Links de mail – Link para e-mail; 

 Named Anchor – Link para um determinado sítio na própria página; 

 Tabela – Insere uma tabela; 

 Imagem – Insere uma imagem na página, este ícone tem várias outras hipóteses de inserção 
de imagens como rollovers; 
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 Media – Este botão tem um sub menu onde existem várias opções para inserção de elementos 
de media (som e vídeo), flash, shockwave, active x, etc. 

 Date – Insere a data na página, embora esta data seja do dia em que o arquivo é modificado 
ou gravado; 

 Comentários – Insere comentários no código fonte da página; 

  Make Template – transforma a página em template (modelo); 

 Tag Chooser – Insere uma tag de várias categorias que podem ser seleccionadas numa janela 
que se abrirá depois de accionado este botão; 
 
Layout 
 
 

 
 

 Tabelas – Tal como na divisão Common tamb´+em da Layout existe o ícone para inserção de 
tabelas; 

  Insert Div Tag -  

 Layers ou Camadas – Camadas; 

 - Visualização do layout, Standard ou normal 

 Frames – Esta função pode ser expandida para inserção de várias disposições de frames; 

 Tabular data – Tabela que é preenchida com dados de uma base de dados ou de um arquivo 
Excel. 
 
Forms 
 
Elementos para criação de formulários. 
 

 
 

 Form – Delimita a acção de um formulário <form> … </form>; 
 Text box - Campo de texto normal de uma só linha; 
 Hidden field – Campo de texto oculto, apenas aparecerá no código HTML. Serve para colocar 

referências a quem recebe os resultados do formulário ou apenas para orientação do webdesigner; 

 Text Área - Campo de texto com múltiplas linhas para textos extensos. É possível determinat o 
tamanho e número de linhas; 

 Checkbox – Insere caixas de verificação para escolha múltipla ou única por parte do utilizador; 

 Radio Button – Insere radio buttons; 

 Radio Group – Grupo de radio buttons nos quais só se poderá escolher uma das hipóteses; 

 List/Menu – Lista de várias hipóteses utilizada muitas vezes para defenir assuntos em 
formulários; 

 Jump Menu – Tal como a List/Menu é composta de várias hipóteses apenas com a diferença 
que servirá de link para outras páginas; 

 Image Field – Permite substituir um botão, de envio (submit) ou reset, por uma imagem; 
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 File Field – Cria um campo de texto e um botão de procura para upload de arquivos para o 
servidor; 

 Button – Botão para envio e para limpar o formulário; 

 Label – É usado para associar determidado texto a um elemento do formulário; 

 Fieldset – Cria uma linha que delimita os campos do formulário que pretender-mos de forma a 
separar os dados por exemplo por categorias. 
 
 
Text 
 
Esta barra tem todos os caracteres e símbolos especiais que não estão no teclado. Aqui descrevo 
os principais. 
 

 
 
Font Tag Editor – abre uma janela para edição de tags no código fonte. 
Bold e Italic – Tal como em qualquer editor de texto atribuem ao texto os parâmetros de negrito e 
itálico; 
 
Paragraph – Insere um parágrafo na página; 
 
 
 
 
HTML 
 
Barra de ferramentas associadas ao código HTML. 
 

 
 

 Horizontal Line – Insere uma linha horizontal. Este elemento não funciona em algumas versões 
do browser Netscape; 

 Meta – Insere uma meta tag no cabeçalho da página, entre <head> e </head>, permite dar 
informação da página aos servidores e motores de busca; 

 Server-Side Include – Inclui  ficheiros ou elementos constantes noutras páginas no ficheiro 
onde estiver inserido. 
 
Application 
 
Os elementos desta barra de ferramentas são usados na criação e ligação a bases de dados e em 
comandos de SQL. 
 

 
 

 Recordset – Faz a ligação a uma base de dados; 
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 Dynamic Data – Este botão exibe as opções de visualização de registos de uma base de dados, 
ou seja exibe os dados nas várias formas, numa tabela, num texto, etc. 

 Repeated Region – Insere uma tabela apenas com os valores dos registos da base de dados; 

 Show Region -  

 Recordset Paging – Cria uma barra de navegação entre as várias páginas para visualização 
dos registos de uma base de dados; 

 Go To Detail Page -  

 Display Record Count – Insere uma descrição do número de registos constantes na página e o 
total constante na base de dados; 

 Master Detail Page Set -  

 Insert Record – Cria um formulário para inserção de registos na base de dados; 

 Update Record – Cria um formulário para consulta e edição de registos numa base de dados; 

 Delete Record – Cria uma página para eliminação de registos; 

 Extenção User Authentication – Exemplo de uma extenção aplicada no Dreamweaver; 
 
 
Texto 
 
A inserção de texto é relativamente simples. O modo quase igual ao Word da Microsoft, com 
algumas características diferentes. 
Por defeito os parágrafos inseridos na página ficarão com uma distância de duas linhas. 
Só se consegue dar um espaço entre as palavras. Para alterar esta definição, como referi no 
capítulo de Personalização do Dreamweaver, deve-se colocas o visto em Allow multiple consecutive 
spaces na categoria General. 
 
Para formatar o texto, procede-se da mesma maneira que no Word: 
 

 
 

 1: Alinhamento do texto; 
 2: Fonte e tamanho; 
 3: Cor. 
 
Por cima da cor o tipo gold ou itálico. 
 
Tal como no Microsoft Word e pelo mesmo processo podem-se fazer listas numeradas com as 
opções que estão por baixo do alinhamento do texto. 
 
Imagens 
 

Para inserir imagens basta accionar o botão  na barra de ferramentas Common (em cima), ou 
visualizar os ficheiros em Files, lado direito, e arrastar a imagem para o lugar pretendido. 
 
Edição de imagens em Fireworks© 
 
As imagens  provenientes no programa de edição de imagens da Macromedia, o Fireworks, podem 
ser editadas. 
Clicando sobre a imagem no painel Properties podemos ver as ferramentas de edição: 
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Na versão MX  

Na versão MX 2004 
No caso do Dreamweaver MX a edição da imagem só poderá ser feita se o Fireworks estiver 
instalado no computador, na versão 2004 pode-se editar directamente no Dreamweaver com as 
ferramentas crop, luminosidade e contraste para editar directamente no Fireworks basta aceder ao 

botão . 
 
 
Imagens Rollover 
 

 
Versão 2004 

 
Versão MX 

 
Podem-se criar imagens rollover ou seja, imagens que ao se passar 
com o mouse sobre elas mudão para outra imagem. É um efeito 
interessante que vale a pena aplicar em certos layouts. 
Para aplicar este efeito basta accionar o botão de Rollover Image e 
dar as directivas na janela que aparecerá igual à imagem seguinte: 

 
 

 
 
Original image: É a imagem que estará visível; 
Rollover image: É a imagem que aparecerá quando o mouse estiver sobre ela; 
Alternate text: é o texto que aparece quando o mouse estiver sobre a imagem – descrição; 
When clicked, Go to URL: é a página destino do link. 
 
 
 
 
 
 
 
 
 
Barra de navegação ou Navigation bar 
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Versão 2004 

 
Versão MX 

 
A barra de navegação não é mais que um botão, a par do rollover 
image, mas com quatro níveis: 
Up: em cima; 
Over: sobre; 
Down: em baixo; 
Over while Down image: quando se dá o clique. 

 
 
São estas as coordenadas que deveremos dar na janela do Navigartion Bar, conforme a imagem 
seguinte: 
 

 
 
 
Elementos Flash 
 

Para inserção de elementos/ficheiros flash na página basta accionar o botão  na barra Insert 
(versão MX) ou a divisória Flash elements da mesma barra na versão 2004. 
 
O Dreamweaver também tem alguns elementos flash já preparados a serem inseridos nas páginas, 
como botões ou texto dinâmico. Para inserir estes elementos no menu Insert > Media > Flash text 
ou Flash Button. 
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Links 
 
A inserção de links, ou ligações para outras páginas (internas ou externas) é relativamente fácil. 
Seleccionamos o texto ou a imagem que pretendemos que seja o link, e no painel Properties 
escrevemos o URL da página, quer sejam páginas do próprio site ou páginas de um site externo. 
 
 
 

 
Texto 

 
 

 
 

Imagem 

 
Para abrir a página numa janela nova basta colocar em Target _blank. Para abrir na mesma janela 
não é necessário qualquer alteração. 
 
Outra forma de inserção de links internos (para páginas do mesmo site) é seleccionar o texto ou 
imagem onde se pretende fazer a ligação e arrastar o ícone  para a página correspondente no 
painel Files. 
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Para “lincar” a um mail basta colocar no caminho do linkl mailto:mail@servidor.com 
 
Anchor 
 
Existe outro tipo de link, os links internos. 
Chamados Anchor (ancora) ou mais usualmente chamados bookmark. Estes links são utilizados 
para ir para determinado sítio da mesma página. Aplicam-se quando a página tem um texto muito 
extenso. Para melhor identificação dos temas são colocados links no início da página. 
 
Seleccionamos uma palavra no sítio para o qual pretendemos direccionar o visitante e accionamos 

o ícone . Abrir-se-à uma janela e damos um nome pelo qual este “sítio” será identificado pelo 
link – Anchor name, aqui ficará marcado com uma pequen. ancora. 
 
No início da página (ou qualquer outro sítio) criamos o link desta forma: 
 
pagina.html#nome_da_anchor 
 
pagina.html – é a página onde estará a anchor, a página que estamos a trabalhar, seguido de # 
(cardinal) e o nome que démos à anchor. 
 
Também podemos fazer vários links numa só imagem. Por exemplo temos vários objectos numa 
imagem e queremos que cada objecto tenha um link para uma página diferente. Para isso, 
seleccionamos a imagem e no painel de propriedades escolhemos um dos ícones Hotspot Tool: 
 

 

- Rectangular; 
- Oval; 
- Polígono – que fará várias formas. 

 
A escolha da forma será feira consoante a forma que queremos aplicar ao link. Na imagem 
aplicamos a área como se estivéssemos a desenhar uma imagem num programa gráfico. 
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A seguir no painel de propriedades define-se o caminho do link e as suas propriedades como se de 
um link normal se tratasse. 

 

 
 
 
 
6. Tabelas 
 
Uma tabela não é mais que uma divisória, composta por linhas e/ou colunas, com a qual dividimos 
a página, ou parte dela, para melhor distribuição dos textos e imagens no layout da mesma. Dar 
uma melhor divisão gráfica da página. 
O comando para inserção da tabela é encontrado na divisória Common da barra de tarefas Insert 

no botão  ou no menu Inser > Table. 
 
A seguir temos a janela de configuração da tabela que passo a descrever: 
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Bordes thickness: é a largura do preenchimento das linhas da tabela; 

Cell Padding: é a distância entre a linha que delimita a tabela e o conteúdo da mesma (texto ou 
imagem); 

Cell Spacing: é a distância entre as delimitações, das linhas e colunas; 

Podemos colorir o fundo ou os limites de uma tabela. Para isso, no menu properties em Bg 
(Background) escolhemos a cor de fundo da célula ou da tabela inteira. Em Brdr é definida a cor 
dos limites e divisórias da tabela. No caso de querermos inserir o número hexadecimal referente a 
determinada cor basta inserir no campo de texto correspondente. 
 
Dica: Para que uma tabela fique proporcional ao tamanho do ecran, seja ele 800 x 600 ou 1024 x 
768, definimos o tamanho em percentagem, caso se pretenda uma medida exacta, definimos em 
pixels. 
 
Para alinhamento do texto, posicionamos o cursor na célula desejada e nas propriedades 
(Properties), em Vert, posicionamento vertical, escolhe-se a posição pretendida na célula. 
 

 
 

Top, Middle, Bottom ou Baseline. 
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Para alinhamento da tabela em relação à página, no painel properties, com a tabela seleccionada, 
em Align define-se a posição Left (esquerda), Right (direita) e Center (centro). 
 
Se não especificar-mos o alinhamento o browser assumirá Bottom como defeito o que fará a 
imagem alinhar à esquerda e ao centro da tabela. 
 

Para unir duas ou mais células basta selecciona-las e clicar no ícone  no painel de propriedades 
ou no menu Modify > Table > Merge Cells (Ctrl+Alt+M). 
 

Para dividir uma célula em duas ou mais partes (colunas ou linhas) clicamos no ícone  ou no 
menu Modify > Table > Split Cell… (Ctrl+Alt+S). 
Aparecerá a janela Split Cell onde se informa o númedo de colunas ou linhas pretendidas. 
 

 
 

Para seleccionar duas ou mais células de uma tabela aleatoriamente, seleccionamos a primeira com 
a tecla Ctrl pressionada, e não a largando, seleccionamos as restantes células pretendidas. 
 
Layout View 
 
O Layout View é o modo de visualizar as tabelas como se estivesse no browser.  A versão 2004 
trás este recurso de forma mais intuitiva do que na versão MX. Esta nova versão suporta textos 
feitos no Microsoft Word e Excel bastando apenas copiar e colar na área de trabalho do 
Dreamweaver. 
 
Inserimos uma tabela e acedemos a esta funcionalidade no menu View > Table mode > ayout 
mode ou Ctrl + F6. Temos assim a página em modo de layout: 
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Neste modo tornarse-à muito mais fácil a inserção inserir células dentro da tabela. No menu Insert 
> Layout Objects > Layout cells. Aparecerá um cursor em forma de cruz para poder desenhar as 
células. 
 
6.1. Ordenar dados numa tabelas 
 
A maneira mais fácil para ordenar os dados numa tabela, alfabeticamente ou numericamente, é 
utilizando a ferramenta Sort Table no menu Commands > Sort Table. 
 
Imaginemos uma tabela como a que se segue: 
 

 
 
seleccionamos a coluna onde consto os nomes e activamos o comando Sort Table em Commands > 
Sort Table. 
 

 
 



 41

Define-se o tipo de ordenamento em Order – alfabético ou numérico, ascendente ou descendente. 
 
Em Sort by pode-se escolher outra coluna que não a seleccionada. 
 
 
7. Image Tracing  / Imagem de “Decalque” 
 
Para quem prefere fazer um rascunho do site num programa gráfico antes de passar à execução no  
Dreamweaver esta é uma boa forma de decalque do rascunho. 
 
Com o image tracing utiliza-se o modelo criado no programa gráfico como se de um background da 
página se tratasse para depois se executar o layout do site em cima do mesmo. 
 
O Image Tracing não é o background da página. 
 
Para aplicar uma imagem ao image tracing basta aceder às propriedades da página. Na versão 6.0 
encontra-se na janela proncipal. 
 

 
 

Na versão 2004 (7) selecciona-se a categoria Tracing Image. 
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Escolhe-se a imagem, em Browse…, e ajusta-se a transparência da mesma. Não é conveniente 
deichar a opcidade a 100% para termos a noção do que é a imagem e os elementos pertencentes 
ao layout da página. 
 
Deverá ficar com este aspecto: 
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Para mover a imagem para um local específico, selecciona-se View > Tracing Image > Adjust 
Position… 

 
 
Na caixa de dialogo ajustam-se as cordenadas X e Y. 
Para poder mover a imagem para a posição inicial basta aceder ao menu View > Tracing Image > 
Reset Position. 
 
 
8. Templates / Modelos 
 
Como o próprio nome diz, Templates são documentos que podem ser usados como modelo para 
outras páginas com o mesmo layout, ou seja, é uma espécie de frame que não separa as páginas 
mas vai buscar partes comuns a um só documento. 
 
Ao definir-mos o desenho principal do site, a área que seja comum a todas as páginas, é 
necessário gravar esta página como Template no menu File > Save as template… 
A página será gravada com extenção .dwt e ficará numa pasta que é gerada automaticamente com 
o nome Templates. 
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De seguida abrimos/criamos uma página em branco e 
aplicamos o template. 
Para aplicar o template basta abrir o painel Files divisória 
Assets e seleccionar o ícone assinalado na imagem para 
visualizar os modelos disponíveis. 
 
Para o aplicar à página basta arrastar o mesmo para a 
página que está em branco. 
 
 
 
 
O astecto da página ficará como a da figura em baixo: 
 

 

 
 

O passo seguinte será criar regiões editáveis ou seja, as regiões que poderão ser modificadas nas 
páginas. Cada página cada assunto, assim cada uma terá um conteúdo diferente. 
Abrimos o template (.dwt) e com o botão direito do ato clicamos na região que pretendemos seja 
editável, escolhemos Templates > New Editable Region…, damos um nome à região e OK. 
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Neste caso criei duas regiões editáveis, Título e Conteudo, ou seja em cada página irei colocar um 
título diferente e respectivo conteúdo da página. 
Para isso basta escrever e colocar o conteúdo dentro das limitações verdes. 
 
 
 
 
9. Lybraries 
 
 
A Lybrarie ou biblioteca é um recurso que facilita o desenvolvimento dos projectos, quando se 
trabalha com elementos utilizados várias vezes no mesmo site. Estes elementos podem ser 
imagens, menus, texto, tabelas, etc. 
 
Para aceder à função Library, no painel Files, divisão Assets e no último botão, conforme a figura 
seguinte: 

 
 

Para adicionar um elemento à lybrarie selecciona-se no layout o elemento que pretendemos 
(imagem, texto, etc.) e carrega-se no botão  que fica em baixo na caixa Assets. 
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Automaticamente o elemento é adicionado à library. Por defeito o objecto terá o nome de 
“Untitled” pelo que o convém mudar para melhor identificação. 

Para colocar um elemento do Library na página, basta seleccioná-lo e arrastar para o lugar 
pretendido. 

 
 
10. Frames / Molduras 
 
Os Frames ou molduras como muitas vezes são designados, são várias páginas inseridas 
simultaneamente no mesmo browser. 
 
Para compreender o uso de frames importa distinguir dois termos: frame e frameset. 
 
Frameset – é o documento html que define a estrutura, ou a divisão, da página em frames 
(número de frames). É o conjunto de frames. 
Frame – é uma página html inserida numa das divisões da frameset. São no mínimo duas. 
Ou seja, existem sempre uma página (frameset) + X páginas (frames). 
 
Criamos uma nova página. Na versão MX encontramos os frames no painel Insert divisória Frames.  
 

 
Versão MX 

 

 

 
 
 
Na versão 2004 os frames estão incluídos na divisória 
Layout conforme a imagem da esquerda. 
 

Com a nova página aberta escolhe-se um dos modelos 
propostos. Neste caso escolhi o modelo com duas frames, 
uma no topo e a outra no rodapé – Top and Bottom Frames. 

Existem vários modelos prontos, porém nada impede fazer 
um frameset diferente. 

 
Após a escolha a página deverá ter esta aparência: 
 



 47

 
 
Como temos agora três páginas inseridas na frameset (página principal) é necessário grava-las. 
Para isso seleccionamos cada uma delas e gravamos. No menu File > Save Frame As… Depois das 
3 frames estarem gravadas será a vez de gravar a frameset para que as frames fiquem nela 
gravadas. Para isso selecciona-se no menu File > Save All. 
 
Dica: Caso as bordas do frameset não estejam  visíveis, deverá acionar a opção no menu 
View>Visual Aids>Frame Borders. 
 
Depois desta operação temos então a frameset e três frames. A partir daqui é só redimencionar as 
divisões da página. Para isso coloca-se o cursor em cima da divisão e puxa-se para onde 
pretendermos. 
 

 

Para definir as propriedades de cada frame, ou seja, 
se têm ou mão borders, scrool bars, etc, vamos ao 
menu Window > Others > Frames na versão MX ou 
simplesmente Window Frames no MX 2004. Abrir-se-à 
no canto inferior direito o Advanced layout, um 
esquema do frameset. 
 
Seleccionamos a frame pretendida e nas propriedades 
são definidas as carcteristicas que a mesma irá ter. Se 
tem ou não barras de navegação (Scroll), borders, etc. 
 

 
No caso de não se pretender que a frame não seja redimensionada em relação ao tamanho do 
ecrân marcamos “No Resize” no painel Properties. 
 
Criar links em Frames 
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Criar o link normal. 
 
Ao atribuir o nome do link, a caixa Target no painel 
de propriedades ficará disponível. Nela, se indicará 
o frame onde se abrirá a página do link (por 
exemplo, mainframe, topframe, bottomframe 
etc…). 
 

 
Podemos também abrir dois links em frames diferentes e ao mesmo tempo. 
Na divisória Behavior > “Go To URL”, na versão MX, e na divisória Tag <a> > Behaviors para a 
versão 2004. 
 

 

No campo “Open In”, selecionar o Frame em que o link será aberto. No campo URL indicar a URL a 
ser aberta. Pode-se fazer isto para cada frame, um link para cada frame. 

10.1. iFrames 
 
iFrame (inline frame) não é mais do que uma janela dentro de uma página onde se abrirá outra 
página. Ou seja, no meio de uma página principal. Não confundir com Frames que são divisões na 
mesma página. 
Para que esta página seja criada usaremos o código fonte (html) com os dados relativos às 
características da iframe. 
 
Para criar um iframe basta incluir o seguinte código na tag <body>, ou seja posicionamos o cursor 
no sitio da página que queremos que o iframe surja, abrimos o modo de code view e colamos o 
seguinte código: 
 
<iframe leftmargin=5 topmargin=5 marginWidth=0 marginHeight=0 src=”pagina.htm” 
frameBorder=0 width=680 height=140 scrolling=yes></iframe> 
 
Nos valores de Margem poder-se-à definir os que se desejar (neste exemplo, todas as margens 
foram definidas com valor “5”). Os valores a seguir são: 
src: indica a página a ser carregada; 
Frameborder – define a espessura da border: 
Width/height – define as dimenções do iframe: 
Scrolling – Yes ou No se quiser-mos ou não as barras de scroll. No caso de pretendermos que as 
barras de scrool apareçam ou não consoante o tamanho da ágina coloca-se “auto”. 
 
É importante dizer que os iframes não são visíveis enquanto editados no Dreamweaver, só se 
tornam visíveis quando testados no browser (F12). 
 
Inserir links no iframe 
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No caso de termos vários links na página principal, e queiramos que os mesmos abram no iframe, 
deveremos em primeiro lugar dar o nome ao iframe. Para isso acrescentamos na tag iframe o 
código name=”nome_iframe”. 
Depois ao inserir-mos o link, tal como nas frames, em target, escrevemos o nome da iframe uma 
vez que não aparecerá na caixa de combinação. Ao contrário das frames, o target não terá o 
underscore “_” no inicio do nome. Ou seja em vez de _nome_iframe será nome_iframe. 
 
È possível inserir iFrames através de extenções e uma das mais úteis e fáceis de usar é a 
MX127851_PDIframe_Object (autor: Public Domain Lda.) não sendo necessário ir inserir 
directamente no código. 
 
 
11. Formulários 
 
Formulários podem ser sinónimo de interacção entre o utilizador e o site. Com eles podem 
efectuar-se pesquisas, comércio electrónico, livro de visitas, registo de clientes ou simplesmente 
enviar contacto entre muitas outras possibilidades. 
Todos os formulários necessitam de uma ligação ao servidor de Internet, ligação esta feita 
geralmente por mei de um script CGI. 
 
Os formulários começam e terminam obrigatoriamente com as tags <form> e </form>. 
 
Atributos dos formulários 
 

 
 

Form name: Nome do formulário; 
 
Method: Método de processamento do formulário – GET envia as informações anexadas como um 
endereço de Internet (URL). É pouco utilizado uma vez que impõe limite de caracteres (8192 
caracteres). POST permite à aplicação receber informação sem impor limite no tamanho da 
informação. 
 
Action: Direcciona o formulário para o aplicativo que processará a informação. Geralmente é 
configurado com uma URL que executará uma aplicação específica (formmail por exemplo). 
 
Target: Informa ao servidor qual a janela utilizada para exibir a resposta de confirmação do 
formulário, tal como nos links. 
 
As ferramentas dos formulários encontram-se na barra Insert, divisória Forms. 
 

 
 

Para inserir um formulário é necessário que antes de mais se insira um form (pimeiro ícone do lado 
esquerdo). Um form é uma área que delimita a acção do formulário (<form>….</form>), ou seja, 
tudo o que faz parte do formulário deverá ser inserido dentro desta área. O form definirá a acção 
que o formulário irá tomar depois de ser premido o botão de Submit ou enviar. Para definir essa 
acção selecciona-se a linha do form, e no painel de propriedades, ou directamente no código html 
defenir-se-à a acção do mesmo. 
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Depois de inserido o Form, podemos inserir não só todos os componentes de um formulário - 
caixas de texto, botões, áreas de texto, etc -  mas também texto, tabelas, imagens e muito mais. 
 
O envio dos dados de um formulário, poderá ser feito através de e-mail (para isso necessitará de 
um formmail ou script de CGI) ou para bases de dados (linguagem dinâmica – ASP, PHP, JSP, 
etc.). 
 
Elementos de um formulário 
 
Text field: É uma área destinada à inserção de dados; 
 
Hidden field: Esta função não ficará visívei na página. É inserido no código e executará uma acção 
no formulário ou simplesmente serve para inserir uma referência; 
 
Text Field: Como o nome indica serve para inserção de texto; 
 
Checkbox: Serve para marcar hipóteses num formulário (tipo visto); 
 
Radio button: Como o checkbox também serve para marcar uma ou várias hipóteses num 
formulário. No caso de pretendermos que dentro de várias hipóteses o utilizador só tenha a 
possibilidade de escolher uma, então insere-se o Radio group; 
 
List menu e Jump menu: O List menu não é mais do que uma lista de hipóteses onde o utilizador 
poderá escolher uma de várias hipóteses, e apresenta-se como na figura de baixo. Se pretender-
mos fazer desta lista um menu de links para outras páginas utilizaremos o Jump menu; 
 
Button (botão): Como o próprio nome indica é um botão, que ao ser accionado realizará uma 
acção. Há duas acções possíveis que poderam ser realizadas pelo botão: Submit form, que irá 
submeter o formulário à acção indicada, e o Reset form que apagará os dados inseridos no 
formulário. 
 

 
 

Este é o aspecto do formulário no browser. 
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11.1. Validar um formulário 
 
Validar um formulário significa atribuir campos de preenchimento obrigatório, ou com determinado 
valor obrigatório, por exemplo só números ou e-mail, etc. 
 
Para validar um formulário vamos usar comportamentos ou Behaviors. 
Depois de inserido o formulário, e com o cursor dentro do mesmo, na barra Design divisória 
Behaviors, na versão MX, e na versão 2004, vamos ao painel Tag divisória Behaviors. Accionamos 
o + > Validate Form. 
 

 
 
Na janela Validate Form configura-se o tipo de dados que se requerem: 
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Value: se marcado o Required significa que o campo é obrigatório ser escrito; 
 
Accept 
Anything: qualquer valor será válido; 
Email address: só serão válidos endereços de e-mail; 
Number: números 
Number from: só seram válidos números entre os limites colocados em número to número. 
 
 
 
 
11.2. Exercício - Help em formulários 
 
O help nos formulários, é uma maneira de mostrar a quem está a preencher o formulário o que 
deve colocar no campo de texto. Claro que este help só fará sentido quando os campos do 
formulário suscitarem alguma dúvida do tipo de informação que se irá introduzir. No entanto fica 
sempre engraçado e mais completo. 
 
Para melhor compreensão na construção desta aplicação convém ver em primeiro lugar os 
capítulos Camadas / Layers e Behaviors. 
 
Criarmos um formulário que tenha um espaço para inserção de camadas. Neste exemplo foram 
criados apenas dois campos de texto, consequentemente, duas camadas. 

 
 

Em cada camada escreve-se a descrição do respectivo campo de texto que irá representar. Por 
exemplo no campo nome a camada respectiva poderá ter: “Aqui escreve o seu nome”. 
 

 

De seguida selecciona-se o primeiro campo e em Behaviors (+) 
escolhemos Show-Hide Layers e no behavior (conforme imagem do 
lado) que ficará visível escolhe-se onFocus. 
 
Repete-se o mesmo processo escolhendo-se no behavior Hide e 
onBlur. 
 
onFocus: em evidência; 
onBlur: sem qualquer evidência (sem foco). 

 
Basta agora fazer o mesmo para o segundo campo de texto e respectiva camada. 
 
Fica assim pronto um “help” para formulários útil em certas situações. 
 
 
12 . Layers / Camadas 
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As Layers ou camadas são um grande recurso que o Dreamweaver possui. Como o próprio nome 
indica são camadas, ou espaços que virtualmente ficarão acima do layout da página. São espaços 
que tal como uma página podem conter os mesmos elementos desta. 
 

As camadas são criadas através do ícone  na barra de ferramentas Insert na divisória Common 
(versão MX) ou divisória Layout (versão 2004). 
 
O cursor assumirá a forma de cruz e tal como num programa gráfico desenhamos o espaço 
(quadrado ou rectangular) da camada. 
 
Depois de inserida a camada convém perceber o painel de propriedades (Properties) da mesma. 
 

 
 
Bg Image: imagem de fundo da camada; 
Bg Color: cor de fundo; 
 
Tag – determina se a camada é CSS ou Netscape. As camadas CSS se baseiam em coordenadas de 
HTML enquanto as da Netscape se baseiam em uma formatação criada por ela mesma.  
 
Overflow - Mantém o tamanho da camada e não exibe o excedente. 
visible: no caso do conteúdo da camada ser maior que esta, o tamanho da mesma é aumentado 
automaticamente quando visualizado no browser; 
hidden: no caso do conteúdo da cmada ser maior, mantém o tamanho da camada e não exibe o 
excedente; 
scroll: coloca as barras de scroll na camada; 
auto: coloca as barras de scroll caso o tmanho do contudo exceda o tamanho da camada. 
 
Vis – indica a visualização inicial da camada: 
default: visualização padrão, sempre visível; 
inherit: Herda a propriedade da “camada-mãe”, ou seja, se esta camada estiver dentro de outra, 
ficará com a propriedade de visibilidade da camada principal; 
visible: Exibe o conteúdo da camada, independente da camada-mãe; 
hidden: oculta não só o conteúdo como também a própria camada. 
 
Dica: Para editar várias camadas ao mesmo tempo, selecione uma ou mais camadas segurando a 
tecla "Shift". Na caixa de Ferramentas aparecerá uma nova opção: "Multiple Layers", onde se 
especificará o novo tamanho ou posicionamento que será aplicado para todas as camadas. 
 
Poder-se-ão fazer coisas bem interessantes com as camadas utilizando acções. Noutros capítulos. 
 
 
13. Adicionar elementos de Media (video e som) 
 
A inserção de elementos de som (mp3, .wav, etc)  ou vídeo (.mpeg, .mov, .swa, etc) é 
relativamente fácil através dos recursos que o Dreamweaver possui embora estes recursos sejam 
um pouco limitados, sendo muitas vezes necessário recorrer à edição do código para 
personalização destes elementos. 
 
Existem no entanto algumas extenções que facilitam esta operação. 
 
13.1. Video 



 54

 
O maior problema encontrado pelos webdesigners em disponibilizar vídeos , é o tamanho dos 
arquivos. Para resolver esta questão, os fabricantes de mídia desenvolveram várias soluções para 
criação, armazenagem e reprodução de mídia digital. Cada solução tem um formato de arquivo 
diferente exigindo assim que o utilizador tenha um sistema de reprodução (plug-in, controle Active-
X ou applet Java) capaz de interpretar esse formato específico. 
 
Existem atualmente três grandes centros de desenvolvimento de midia streaming: RealMedia , 
QuickTime e Windows Media. Juntas representam actualmente todo o mercado de Mídia virado 
para internet. 

 
 

Para inserir um elemento de vídeo numa página existem dois processos, utilizando um link ou 
utilizando uma tag <embed>. 
 
No caso de utilização de um link 
 
Selecciona-se o texto ou imagem que irá servir de link para o arquivo de vídeo, e no painel 
Properties coloca-se o respectivo arquivo. 
Convêm colocar o tamanho do arquivo ao lado do texto do link para informar o utilizador. 
 
 
Utilizar a tag <embed> 
 
Deste modo obter-se-à mais controle sobre a reprodução do filme uma vez que será incorporado  
na página através da tag <embed>. Ao alterar os atributos desta tag é alterado o modo de 
visualização do vídeo. 
 
No menu Insert > Media > Plug in, na barra Insert, Media ou simplesmente arrastando o ficheiro 
do painel Assets Movie. 
Ao inserir este objecto plugin, este apresenta dimensões padrão de 32 x 32. Para modificar estas 
dimensões vá em Properties e insere-se os valores para W e H, largura ou altura ou selecciona-se o 
objecto no layout e no canto inferior direito aparecerá um quadrado de redimencionamento. 
 
Streaming em RealMedia 
 
O download de arquivos vídeo numa ligação por modem tornam-se mais rápidas e eficazes graças 
ao surgimento do Vídeo Streaming. Esperar até que o download  do arquivo de vídeo seja feito, 
pode levar uma eternidade.  
Ao incluir RealMedia nas páginas , podemos fazer com que o RealOne Player do utilizador flutue na 
página, bem como pode especificar que o vídeo apareça inline (em uma área específica da página). 
Pode-se também personalizar os controles que aparecem na página. 
 
Criar arquivos RealMedia 
 
O RealMedia utiliza o seu próprio software de servidor chamado RealServer para transmitir os 
arquivos de vídeo codificados. Em vez de chamar esse servidor e o arquivo de vídeo diretamente, o 
RealMedia utiliza o sistema de metarquivos para vincular ao servidor o arquivo de RealMedia. O 
metarquivo nada mais é do que um arquivo de texto comum (txt) contendo o URL que selecciona o 
arquivo de vídeo para o RealServer. O que difere dos arquivos de midia são as extensões: 
 
arquivos RealMedia = .rm , .ra , .rp , .rt , .swf 
arquivo que carrega o RealOnePlayer independente = .ram 
metarquivo que carrega o RealPalyer Plug-In = .rpm  
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Para criar um metarquivo , abrimos o bloco de notas, ou notepad,  e inserimos uma linha que 
direccione para o caminho do arquivo de vídeo, com a diferença de ai invés de utilizar http 
usaremos rstp (Real Time Streaming Protocol), ou seja: 
rstp://www.paulosilva.net/vídeos/arquivo.rm.  
 
Inserir RealMedia 

Uma vez o arquivo codificado e o metarquivo de RealMedia, vamos inseri-los na página. 
Inserimos um link e configura-se o atributo href para o endereço do metarquivo: 
<a href="vídeos/materia_dw.ram">Video</a> 

Podem-se inserir vários arquivos de vídeos no mesmo metarquivo, basta para isso colocar um em 
cada linha, separada por um único retorno. 
Quando o link é accionado vai chamar o metarquivo, que por sua vez , chama o arquivo de vídeo 
no RealOnePlayer. Assim que o arquivo começa a fazer o download para o usuário, o RealOne 
Player é activado e começa a exibir o vídeo numa janela de vídeo independente. 
 
 
13.2. Som 
 
A inserção de som é muito parecida com a inserção de vídeo. 
 
Para inserir um elemento de som, tal como no vídeo basta ir ao menu Insert > Media > e o plugin 
respectivo, Applet, Active X ou Plugin (Win Media Player). Escolher o arquivo de som e será 
inserido na página o ícone referente ao plugin. 

 

ícone do Plugin Windows Media Player 
 
Para redimencionar o plugin que ficará visível na página, basta seleccionar o ícone e apareceram 
umas alsas de redimensionamento no mesmo. 
 
 
Inserir som de fundo numa página 
 
Para inserir som de fundo numa página basta colocar na tag body do html o seguinte código: 
 
<bgsound src=”som.wav” loop=”infinite”> 
 
 
“Lincar” a um ficheiro de audio 
 
Também se pode criar um link para um ficheiro de áudio. Neste caso ao clicar no link abrir-se-à o 
player que estiver por defeito no computador do utilizador para reprodução do ficheiro. 
 
Para isso basta seleccionar o texto ou imagem do link e seleccionar na caixa de texto do link o 
respectivo ficheiro de som. 
 
 
 
 
 
 
14. Timeline / Linha de tempo 
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Embora este recurso não estivesse inicialmente disponível na versão MX 2004 foi incluído no 
update 7.0.1 que a Macromedia disponibilizou aos utilizadores. 
 
É um recurso que traz grande dinamismo às páginas. Com ele podem-se programar acções com 
recurso a uma linha de tempo a par do que se passa no Macromedia Flash. 
 
O uso de timelines implica a inserção de  códigos de Javascript no cabeçalho do documento, 
<head> … </head>. Isto é feito dinamicamente pelo Dreamweaver sem termos de nos preocupar 
com isso, embora convenha saber, pois muitas vezes é necessário alterar certas acções 
manualmente. 
 
Para aceder a esta funcionalidade vamos ao menu Window > Others > Timelines ou Alt + F9. abrir-
se-á o painel do Timeline: 
 

 
 

Para mostrar esta função vamos construir um evento. 
 

 

Inserimos uma camada (layer) com uma 
imagem, tabela ou simplesmente texto dentro 
da mesma. Adicionamos esta camada à 
timeline. Para tal arrasta-se a camada até à 
primeira “frame” da linha do tempo, conforme 
a imagem do lado esquerdo. 
 
Aparecerá automaticamente a roxo, um layer 
na linha de tempo até à casa 15, que 
corresponderá ao número de frames em que 
decorrerá a acção.  
 

 
 
O número de frames está no campo entre as 
setas. 
 
Em Fps temos a velocidade a que a acção 
decorrerá, ou seja 15 frames por segundo. 
Este campo ficará activo logo após termos 
arrastado a camada para o primeiro frame. 
Se pretender-mos reduzir ou aumentar o 
tempo de acção basta alterar estes valores. 

De seguida movemos o indicador da acção, a vermelho, para a casa 15 e arrasta-se a layer para 
outro local da página (layout). 
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Para que a animação seja executada logo após a página ser carregada devemos marcar o Autoplay, 
e para que a animação seja de uma forma contínua Loop. 
Podemos também introduzir uma pausa no início da animação. Para isso clicamos no meio da linha 
de tempo respeitante à camada e arrasta-se algumas frames (ou quadros) à frente, para a posição 
pretendida. 
 
14.1. Exercício - Acção OnKeyPress 
 
Esta é uma acção simples que consiste em, ao digitar uma tecla a camada baixa. 
Inserimos uma camada com uma imagem ou menu que descerá. Adicionamos a mesma à timeline. 
Criamos uma animação com 15 frames, onde o frame 1 é posição inicial e o frame 15 é a posição 
final. 
Criam-se 13 Keyframes, do frame 2 até o 14 e adiciona-se ao frame 2 um behavior: “Stop 
Timeline” na linha "B" da timeline. 
Agora, selecionamos este behavior, copia-se e cola-se até ao frame 14 (automaticamente, as ações 
são adaptadas ao novo frame). Adicionamos à tag Body o Behavior Play Timeline e como evento, 
OnKeypress. 
A acção fica assim comcluída. 
 
 
 
 
15. CSS - Cascading Style Sheet 
 
As folhas de estilo ou Cascading Style Sheets (ou ainda definições de estilos em cascata), 
geralmente denominadas por CSS são acções inseridas no código da página que vão desencadear 
um determinado acontecimento. As CSS foram criadas e tornaram-se padrão em 1996 pela World 
Wide Web Consortium (W3C). São disso exemplo mais comum a alteração do formato do cursor, 
tirar o sublinhado aos links, criar uma mensagem especifica na barra de status do browser, 
eliminar as barras de rodagem (scrool bar), etc, etc. 
Permite controlar, efetivamente, o desenho de um site. 
 
Convém salientar que só os Browsers Internet Explorer versão 4 ou superior permitem visualizar 
eficientemente os estilos CSS. A codificação CSS será reconhecida automaticamente pelo browser 
que estiver preparado para a reconhecer. 
 
As folhas de estilo podem ser inseridas directamente na página ou em arquivos externos ao 
documento. 
 
A aplicação de um CSS implica a inserção de um código específico no HTML entre as tags <HEAD> 
e </HEAD> que será a função ou referência: 
 
<style type="text/css"> 
<!— icio do css --> 
código 
<! – fim do css -- > 
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</style> 
 
E entre as tags <BODY> e </BODY> que será o local onde a função irá ser executada: 
 
<H1                               style=”nome do estilo”></H1> 
<P style=”nome do estilo”></P> 
 
 
As folhas de estilo ou CSS também podem ser aplicadas num arquivo externo, geralmente com 
extenção .css, evitando assim colocar uma função que seja igual a várias páginas em todos os 
<HEAD> das mesmas, bastando para isso relacionar o código do <BODY> com o respectivo fichiro. 
Neste caso a referência a este arquivo é colocada no head desta forma: 
 
<LINK REL=”stylesheet” TYPE=”text/css” HREF=”estilo.css” TITLE=”ESTILOS”> 
ou 
<style> 
<!— 
@import “estilo.css”; 
-- > 
</style> 
 
 
Trabalhar com folhas de estilo no Dreamweaver é muito fácil e agradável. As operações são 
interativas abrangendo, praticamente, toda a especificação recomendada. 
 
O painel onde poderemos aceder à inserção de códigos CSS encontra-se em Design (lado direito) 
divisão CSS Styles em ambas as versões. Na versão MX 2004 a edição de folhas de estilo torna-se 
mais facilitada. Logo no painel de abertura temos a possibilidade de escolher modelos existentes. 
 

 
 

Abrir-se-à a janela onde se pode escolher as CSS a aplicar na página ou modelos de páginas com 
CSS inseridas, em Page Designs (CSS). 
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Para melhor compreendermos o funcionamento de inserção de um CSS vamos Ao painel, Design do 
lado esquerdo, e seleccionamos a divisória CSS Styles (igual em ambas as versões): 
 

 

No painel de CSS (à esquerda) clicamos no sinal mais, em 
baixo, para inserir um novo estilo. Abrir-se-à a janela de 
diálogo New CSS Style: 
 

 
 
Em Name dá-se o nome que queremos atribuir ao estilo. 
È importante referir que o nome do estilo deverá ter um 
ponto antes, sem o qual correr-se-á o risco de não 
funcionar - .nome_css. 

 
Em Type deixa-se em Make Custom Style (class), ou seja, como folha de estilo padrão. 
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No Define In, refere-se a origem do CSS, se no documento (head) ou num arquivo à parte (.css). 
Consideremos que o estilo será inserido no head da página – This Document Only. OK. 
 
Agora é definido o estilo a criar. 
 

 
 
Em Category, e como o nome indica, são as categorias de estilos, Tipo de texto e links (Type) 
fundo da página (Background), Campos de texto (box), etc.. 
 
Para exemplificar melhor, irei definir um estilo em que a imagem de fundo da página não se 
repetirá. 
 
Então escolhe-se a categoria Background. 
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Escolhe-se a imagem em Background Image e em Repeat dá-se a instrução “no-repeat”. Está 
assim criado um estilo. 
Para aplicar o estilo à página, basta posicionar o cursor em qualquer sítio da mesma e clicar no 
estilo que deverá estar no painel de CSS Style: 
 

 
 

15.1. Exercício – Aplicação de CSS em links 
 
Neste exercício vamos tirar o sublinhado que por defeito é automaticamente aplicado nos links 
pelos browsers. 
È importante referir que a versão 2004 traz já uma pré definição nas propriedades da página onde 
se poderá atribuir esta característica ou seja retirar o sublinhado aos links. Embora esta 
possibilidade esteja disponível é sempre útil aplicar esta folha de estilo uma vez que podemos 
aplicar o sublinhado só a alguns links de uma página e não a todos. 
Então abre-se o painel CSS Style, em Design, e clicamos no sinal +. Atribuímos um nome, por 
exemplo .links, e não esquecer o ponto antes do mesmo. 
Neste caso aplica-se só ao documento que estamos a utilizar – This Document Only. OK 
Categoria Type. Marca-se none em Decoration. 
Para aplicar o css aos links pretendidos basta seleccionar o link e clicar em cima do estilo criado no 
painel CSS Style. 
No caso de existir alguma dificuldade em aplicar o estilo, poderemos ir directamente ao código e 
colocar style=”estilocss” na respectiva tag: 
 
<a href="http://www.site.pt" class="estilocss">Texto</a> 
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A versão 2004 do Dreamweaver trouxe uma nova forma de 
edição dos CSS.  
Permite modificar e acrescentar propriedades às folhas de estilo 
de uma maneira mais fácil e de melhor visualização (imagem 
do lado). 
 
Para que o painel de edição fique disponível basta um duplo 
clique no estilo pretendido e abrir-se-à automaticamente o 
painel Rule. 
 
A edição dos estilos pode ser acompanhada tanto na visão 
Design como na visão de código, bastando para isso colocar o 
layout em code view. 
 
 
 
Na versão 6 dá-se duplo clique no estilo que se pretende editar 
e abre-se a mesma janela de inserção de CSS.  

 
15.2. Exercício – CSS no bachground 
 
Neste exercício vamos aplicar um CSS em que não deixará repetir o fundo da página. Para isso 
vamos ao painel de CSS, na versão 6 ou 7, e accionamos o +. Damos o nome (não esquecer de 
colocar um ponto antes do nome) e OK. 
 

 
 
Atribuímos uma imagem de fundo em background image, e em Repeat temos 4 opções de 
repetição da imagem de fundo da página: 
 
No-repeat: não repete a imagem, ou seja, só aparecerá uma vez no canto superior esquerdo; 

 



 63

 
 
Repeat: repete. É a configuração base, ou seja é a que é aplicada por defeiro repetindo a imagem 
infinitamente na página; 
 

 
 

Repeat-x: Repetirá a imagem de fundo apenas na primeira linha – na horizontal; 
 

 
 

Repeat-y: repete apenas na primeira coluna – na vertical. 
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Em vertical e horizontal position podemos determinar a posição da imagem de fundo em relação 
aos limites do browser. Topo, meio, direita esquerda ou em baixo. Esta característica só terá efeito 
quando aplicada com no-repear, repeat-x ou repeat-y. 
 
 
16. Behaviors / Comportamentos 
 
Como o próprio nome indica comportamentos são acções executadas mediante uma acção do 
utilizador ou do browser. Ou seja comportamento é a combinação de um evento e de uma acção. 
Um evento pode ser um clique ou até mesmo o carregamento de uma página no browser. 
 
Para aceder ao painel Behaviors, no menu Window > Behaviors ou Shift + F3. 
Na versão 6 o painel Behaviors encontra-se em Design (lado esquerdo) e na versão 2004 em Tag. 
 

 

O painel Behaviors, tal como expliquei, é formado por duas 
colunas: Eventos e acções. 
 
Eventos referente ao acontecimento. Carregamento da 
página, movimento do mouse, clique ou duplo clique, etc. 
 
Acções referente à acção desencadeada pelo evento. Abrir 
nova janela, paragem de scroll, etc. 

 
Para inserir um comportamento, selecciona-se o elemento onde se vai gerar a acção que pode ser 
uma imagem, texto, layer (camada) ou simplesmente a página. No caso do comportamento se 
referir à página em si, não é preciso seleccionar nada pois ficará anexada ao elemento body do 
HTML. 
 
Depois de seleccionado um elemento pressiona-se o + no painel e é apresentada uma lista dos 
comportamentos disponíveis.  
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Geralmente, por defeito só serão mostrados os eventos referentes à versão 3 do Internet Explorer 
(IE) pelo que são muito poucos. Como hoje em dia já é muito raro haver versões tão remotas de 
browsers a funcionar, convem criar Behaviors para a versão 5.5 do IE. Para que apareçam todos os 
eventos na lista, em “Show Events For” escolhe-se a versão 5.5 (ou superior). 
 
A partir daqui já se pode escolher uma das acções disponíveis.  
 

 
Aparecerá a acção do lado direito e o evento do lado esquerdo, que por defeito aparece onLoad 
(poderá aparecer qualquer outro). Para modificar o evento clicamos na seta selectora do mesmo. 
 
Alguns eventos mais usuais: 
 
onLoad – quando a página acaba de carregar 
onClick – ao clicar com o mouse 
onMouseOver – ao estar com o mouse em cima de 
onMouseOut – ao sair com o mouse de cima de 
onScroll – ao fazer scroll com a página 
 
 
Existem 27 comportamentos no Dreamweaver mas poderão ser anexados mais. 
O Dreamweaver tem a opção de adquirir mais comportamentos. Para isso no final da lista de 
acções existe uma opção chamada “Get More Behaviors…” que requer ligação à Internet e que nos 
levará para uma página da Macromedia onde se poderão adquirir mais comportamentos. 
 
Para além de adquirir mais comportamentos poderão ser criados pelo utilizador. 
 
 
16.1. Exercício - Menu dinâmico 
 
Vou exemplificar a aplicação de comportamentos na criação de um menu dinâmico muito utilizado 
nos sites. 
Trata-se de um menu que ao passar o mouse em cima de cada “item” abrirá um sub-menu com 
mais opções. 

Inserimos várias imagens ou uma tabela onde ficará o menu principal, a base do menu.  

 

 

Sobre a célula do Menu 1 inserimos uma camada (layer) e dentro 
desta uma outra tabela mas apelas com uma coluna e várias 
linhas. É nesta tabela que ficará o sub menu. 

Depois do Menu principal e sub menu criados vamos aplicar o 
Behavior que fará com que o sub menu desapareça da página e só 
apareça quando o mouse estiver em cima do Menu 1. 

Selecciona-se o texto de Manu 1 e no painel de behaviors > + seleccionamos o evento Show-Hide 
Layers – Mostrar ocultar camadas. 

Irá abrir-se a janela de diálogo Show-Hide Layers. Seleccionamos a layer e acciona-se Show (neste 
caso só aparecerá um elemento uma vez que é o primeiro a ter um comportamento). 
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Depois de inserido o evento teremos de alterar a acção adoptada, por defeito, pelo Dreamweaver 
que não será certamente a pretendida. Seleccionamos então no combobox onMouseOver. 

 

Toda esta operação de atribuição do comportamento é repetida e ao invés de Show em Show-Hide 
Layers selecciona-se Hide. A acção será onMouseOut. 

Todas estas operações feitas para o Menu 1 serão repetidas para a camada com uma diferença. No 
fim de aplicado o behavior e ainda com a camada seleccionada no painel de Properties selecciona-
se em Vis “hidden”. 

 

O menu fica assim pronto. 
Uma vez que ao aplicar-mos a propriedade hidden a camada desaparecerá do layout, podelos 
voltar a colocá-la visível seleccionando o ícone em forma de “C” que se encontra no inicio da 
página. 
 
 
17. Testar o site nos vários browsers 
 
No inicio os browsers resumiam-se ao Netscape Navigator e ao Internet Explorer, o que facilitava a 
compatibilidade entre ambos perante as diversas linguagens de programação web e as várias 
componentes do HTML. 
 
Hoje existem o Internet Explorer, o Opera, O Safari (da Mac), o Firefox entre outros. O resultado 
do aparecimento de vários browsers distintos é a visualização dos sites em cada um deles poder 
ser diferente. A única solução é fazer testes com os diferentes browsers ou obedecer aos padrões 
do W3C (www.w3c.org). 
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O Dreamweaver possui um recurso muito útil para testar os sites nos vários browsers que é o 
Browser Targeting Check. 
 
Com a página aberta, vamos ao menu File > Check Pages > Check Target Browsers. 
 

 
 
Em primeiro lugar é necessário fazer a validação dos diversos browsers. Para isso clicamos na seta 
verde, do lado esquerdo. 
 

 
 
Nesta janela escolheremos os browsers pretendidos e a versão. 
 
Para iniciar a validação dos browsers, vamos à seta verde e escolhemos uma das seguintes 
opções: 
Check Target Browser – só no documento aberto documento ; 
Check Target Browser for entire Sites - em todo o site ;  
Check Target Browser for Select Files/Folder - só nos arquivos selecionados. 
 
Para ter acesso a mais detalhes podemos clicar no botão Browse Report ( ). È visualizado no 
browser um resumo de erros e chamadas de atenção. 
 
 
18. FTP 
 
 
O Dreamweaver possui um FTP excelente para publicação e actualização de páginas num servidor 
de Internet. 
 

Ao lado direito da área de trabalho no menu Files, divisão Site temos o ícone  que nos abrirá a 
área de FTP. 
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Um FTP é composto por duas partes, na esquerda a visualização dos arquivos do servidor, e do 
lado direito são visualizados os arquivos do nosso computador. Neste caso os arquivos referentes 
ao site. 
 
No caso do site não ter o servidor configurado aparecerá a mensagem que vemos do lado 
esquerdo. Podemos clicar no link “define a remote site” ou voltar à definição do site e na categoria 
Remote Info informamos os dados do servidor. 
 

 
 

Access: seleccionar FTP; 
FTP host: o domínio do servidor (ftp.servidor.com ou 125.225.32.256); 
Host Directory: Pasta específica do servidor – pode ficar em branco; 



 69

Login: login de utilizador; 
Password: password. 
 
Na versão 2004 existe a possibilidade de codificar a transferência de arquivos o que evita o acesso 
não autorizado aos dados e arquivos. Para activar esta opção basta colocar o visto em Use secure 
FTP. 

 
 

Expandimos o FTP em  na versão 6 ou em  na versão 2004 e fazemos a conecção com o 
servidor. 

Para isso clicamos no ícone . Depois da ligação feita com o servidor é altura para transferir 
ficheiros. 
 
Para transferir ficheiros para o servidor remoto – upload - basta arrasta-los do ambiente do nosso 
PC (lado direito) para o servidor (lado esquerdo), ou através do botão de upload. Para 
transferência de ficheiros do servidor para o PC – download – a operação é inversa. 
 

 
 
1 – Lista de arquivos; 
2 – Mapa do site; 
3 – Download; 
4 – Upload; 
5 – Fechar FTP. 
 
A visualização do mapa do site torna-se bastante útil quando o site começa a ficar extenço. Nele 
podemos visualizar toda a estrutura do site, suas ligações e arquivos. 
 
 
19. Expandir o Dreamweaver - Extenções 
 
 
O Dreamweaver possui um recurso que lhe permite expandir os seus recursos e funcionalidades 
sem limite através das extenções. 
 
As extenções são aplicativos que instalados no Dreamweaver acrescentam funções e operações ao 
programa. 
Estas extenções são instaladas através do Macromedia Extention Manager, programa instalado 
juntamente com o Dreamweaver. 
 
Para aceder ao Macromedia Extention Manager podemos ir através do menu Iniciar do Windows. 
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Estas extenções são desenvolvidas pela Macromedia e grande parte delas por profissionais 
externos à empresa. O download destas extenções podem ser feitas no site da macromedia em 
www.macromedia.com/cfusion/exchange/index.cfm. 
 
Para as instalar seleccionamos no combobox o programa Dreamweaver e de seguida clicamos no 
botão de instalação. 
 

 
 

Para desinstalar basta seleccionar a extenção e clicar no ícone . 
 
Como utilizar ou aplicar uma extenção 
 
Para saber qual o comando para utilizar uma determinada extenção, deverá seleccionar-se a 
respectica extenção no Extention Manager e aparecerá na parte inferior do mesmo não só a 
descrição do comando mas também da função da extenção. 
 
Caso se instale uma extenção com o dreamweaver aberto convém fechá-lo e voltar a abrir. 
 
 
20. Avançadas 
 
 
20.1. Commands 
 
O menu Commands ou Comandos é um recurso muito útil no que respeita a funcionalidade e 
economia de tempo. 
 
Neste menu existem vários tipos de comandos que podem ser criados, editados ou gravados, 
alguns deles pertencentes a extensões instaladas. 
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Por defeito temos no menu Commands: 
 
Start/Play – Grava e reproduz um comando temporário; 
 
Edit Command List – Edita a lista de comandos; 
 
Get more commands/Manage Extentions – Faz o download e manuseia novos comandos ou 
extenções. 
 
Abaixo destes temos os comandos que para formatar e limpar o código fonte além de criar um 
script que faz o redimensionamento no browser Netscape. 
 
Existe também um comando para criação de um album de fotografias juntamente com o 
Macromedia Fireworks, múltiplos esquemas de cor para sites e formatação e ordenação de tabelas. 
 
Todos os comandos criados iram aparecer na última “ranhura”. 
 
Criar um comando 
 
A forma mais primitiva de aplicar um comando é o Ctrl+Y que repete a última modificação ou 
edição feita. Embora este comando seja muito útil tem um se não, ou seja quando fizermos uma 
edição ou modificação a seguir, a anterior ficará sem efeito. 
Por isso a criação de Commands é muito mais eficaz.  
 
Uma das maneira de criar um command é no menu Commands > Start/Play Recording. Embora 
esta acção seja também temporária. 
 
Activa-se esta opção e executamos a acção que queremos gravar como comando (por exemplo 
criar uma tabela). 
Para terminar voltamos ao menu Commands > Stop Recording. 
 
Para aplicar o comando voltamos ao menu Commands e seleccionamos Play Recorded Command. 
 
Outro método de gravar commands, e que irá gravá-los no mesmo menu, o history (Ctrl+F10). 
 
Criamos um objecto, por exemplo uma tabela, e fazemos várias modificações, de cor, tamanho, 
etc.  
 
No painel History todas estas acções vão sendo gravadas. Depois de terminadas todas as 
operações, seleccionamos todas ou só as pretendidas e guardamos com o botão Save Selected 
Steps as a Command. Damos um nome ao comando e OK. 
 
No menu Command aparecerá o comando criado. 
Para eliminar alguns comandos criados, vamos a Command > Edit Command List e abrir-se-à uma 
janela com todos os comandos criados e a opção Delete. 
 
Obs. Nem todos os comandos podem ser gravados. Quando uma destas operações (no painel 
History) estiver marcada com um X vermelho indica que o mesmo não pode ser gravado. Exemplo 
disso são algumas alterações no código fonte. 
 
 
20.2. Código Fonte – Code Hint 
 
Conforme a aprendizagem na criação de sites vai evoluindo, e os projectos se tornam mais 
complexos, apesar de no Dreamweaver não ser necessário, notaremos que em alguns casos, se 
torna mais fácil a edição do código directamente no mesmo. 
Como o código HTML é uma linguagem exacta, basta enganarmo-nos numa letra de uma tag por 
exemplo para que um determinado elemento não apareça ou dê erro.  
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Para evitar estes erros existe o Code Hint. Um recurso muito útil para quem gosta de editar o 
código. 
 

 

Logo que escrevemos as primeiras letras do código aparecerá 
uma pequena janela com as opções possíveis de código. 
 
A isto se chama Code Hints. 
 
Todos os Code Hints ficam armazenados na base de dados da 
Tag Library do Dreamweaver e podem ser modificadas em  
Edit > Tag Libraries… 
 

 
 

 
 
Estão disponíveis para as linguagens HTML, CFML, ASP.NET , JSP , JRun , ASP , PHP , Modelos do 
Dw (Template) e WML. 
Por defeito estão activos. Para desactivá-lo ou controlar a velocidade que a pequena popup 
aparece, em Edit > Preferences > Code Hints. 
 
Para além de código, ou puro texto, o Code Hint também nos dá a possibilidade de escolher cores 
da paleta. 
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Ou atribuir um tipo de letra específico através de uma lista. 
 

 
 
 
20.3. Código Fonte - Meta Tags 
 
As meta tags são tags ou linhas de código que colocadas entre o <head> e </head> dão 
informação aos servidores e motores de busca da Internet acerca do site ou do webdesigner. 
 
Nas meta tags deverá ser incluída toda a informação útil que o site queira transmitir ao utilizador 
uma vez que alguns motores de buscam seleccionam esta informação para a colocarem nas suas 
bases de dados para futura pesquisa dos internautas. 
 
No caso de estarmos familiarizados com o código, esta informação pode ser escrita directamente 
no HTML. Mesmo assim, para facilitar esta operação o Dreamweaver possui um comando que 
insere meta tags no código da página. 
 
Para aceder a este comando, na versão 6, vamos ao menu Insert > Tag…. 
 
Aparecerá a janela de inserção de código. 
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Para além das meta tags esta função permite inserir outros elementos na página como links, 
frames, formulários etc. 
Expande-se a pasta de HTML Tags, seleccionamos Page Composition e do lado esquerdo 
escolhemos meta. Clica-se em Insert. 
 

 

Abrir-se-à a janela Tag Editor onde se insere 
toda a informação desejada. 
Em Name informa-se o tipo de informação. A 
descrição. 
Em HTTP-Equiv o comando referente à 
informação dada no Name ou seja caso a 
página tenha uma validade inserimos a data de 
validade em Name e Expires em HTTP-Equiv. 
 
Content é a descrição ou simplesmente palavras 
chave. 

 
 
Na versão 2004 o acesso a esta funcionalidade é mais fácil, no menu Insert > HTML > Head Tags 
> Meta. 
Abre-se então a janela para inserção da meta tag. 
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20.4. Server-Side Includes (SSI) 

 
As SSI são comandos que permitem incluir arquivos em determidado local da página, mediante 
interpretação do servidor. Estes includes só seram visualizados no Dreamweaver ou no servidor 
através do browser, nunca no nosso computador. 
 
Por exemplo, queremos inserir um rodapé na página igual em todo o site. Em vez de o fazermos 
em cada página, esse rodapé estará gravado em apenas um arquivo. 
 
Criamos uma tabela com apenas uma linha e uma coluna. Escrevemos por exemplo Copyright © 
2004 conforme está no exemplo. 
 

 
 
Antes de guardar esta página vamos ao código e apagamos tudo o que esteja antes e depois de 
<table> e </table> para que o servidor não interprete o código como sendo um novo arquivo 
HTML uma vez que a página onde irá ser incluída esta tabela já tem os comandos <html>, 
<body>, etc.. 
Grava-se como .htm ou .html. 
 
Cria-se a página principal onde irá ser incluída a tabela de rodapé e grava-se esta com extenção 
.shtml (não pode ser .html ou .htm). 
 
Para inserir o include, na versão 6, no painel de ferramentas insert, divisória Script, ícone Server-

Side Include ( ). No MX 2004 vamos à divisória HTML da barra de ferramentas, expande-se o 
ícone Script (último) e seleccionamos Server-Side Include. 
 

 
 
Selecciona-se o arquivo gravado anteriormente. A tabela aparecerá no local escolhido, neste caso 
no rodapé. 
 
No código HTML não aparecerá o código da tabela mas apenas o código do include que será: 
<!--#include file=”arquivo.html”--> 
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Esta configuração é muito útil uma vez que basta modificar uma página (include) para que em 
todas as páginas do site onde esta esteja incluída seja modificada. 
A par dos templates esta é uma forma de facilitar o trabalho do webdesigner quando se trata de 
manutenção e actualização de partes comuns às várias páginas de um site. Cabe ao webmaster 
decidir a melhor opção. 
 
20.5. Snippet 
 
Os Snippet são códigos de de html, java script, meta name entre outros que o Dreamweaver 
disponibiliza e que estão prontos a serem aplicados no código da página. 
Para aceder aos Snippet Window>Snippet. O menu ficará disponível na caixa de ferramentas Code 
do lado direito, na divisão Snippet. 
 

 
 
Estes códigos são geralmente colocados no <head> da página, excepto quando indicado no 
comentário do próprio código ou script. 
 
Os códigos de Java Script deverão ser colocados entre as tags <script language=”JavaScript”> e 
</script> 
 
 
20.6. Procura e substituição de texto / Results 
 
Este recurso existente no Dreamweaver, facilita-nos a localização de um nome ou frase, em todo o 
site, e sua substituição ou eliminação. Este recurso revela-se muito útil quando o tamanho do site 
começa a ter de grandes dimensões. 
 
Para aceder a este recurso vamos ao menu Edit > Find and Replace … ou Ctrl + F. 
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Em Search escolher Text (texto), escrever palavra ou texto a procurar em Find e o texto a 
substituir em Replace. No caso de pretender apenas localizar o texto, basta escrever o mesmo na 
caixa Find. Ao ser localizado o programa evidencia o texto. Se pretender-mos continuar a procurar 
basta clicar em Find Next. 
O texto inserido na procura é mantido em memória até que seja substituído. Se se pretender uma 
nova busca com o mesmo texto basta ir a Edit > Find Next e localizará novamente as mesmas 
palavras. 
 
Podemos também localizar todas as ocorrências já procuradas, bastando clicar no botão Find All 
abrindo-se a divisão  Search no painel Results, em baixo. 
 

 
 
Localizar Código 
 
Se por exemplo, decidirmos alterar um nome específico para tipo de letra negrito , azul , 5 pontos, 
em  todas as páginas do site fazemos o seguinte: 
 
1. escolha Edit > Find and Replace; 
2. em Find in escolhemos Current Document, Entire Current Local Site, Folder…; 
3. na lista Search escolhemos Source Code; 
4. insira o código actual em Find: por exemplo  
<font color="#FF0000" size="4"><strong>cliente</strong></font>  
5. inserimos o novo código em Replace:  
<font color="#0000FF" size="5"><strong>cliente</strong></font>  
6. Find Next ou Find All e Replace  ou Replace All. 
 
Pesquisa avançada 
 
Podem-se fazer também pesquisas avançadas como por exemplo procurar um nome que esteja só 
no cabeçalho ou rodapé das páginas. 
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Para isso escolhemos Text (advanced) em Search. 
 

 
 
Aparecerá uma nova opção de escolha com dois botões (sinal + e -) para poder adicionar ou 
remover critérios de selecção. 
 
 
 
20.7. Configuração de um site com programação 
 
Para definir um site com programação, (PHP, ASP, JSP, ColdFusion, etc.), utilizamos o mesmo 
método que numaconfiguração normal vamos ao menu Site > Edit Sites… (versão 6) ou menu Site 
> Manage Sites (versão 2004) categoria Testing Server. 
 

 
 
Server Model, é o modelo ou tipo tecnologia de servidor que iremos utilizar. Neste caso escolhi o 
PHP MySQL. 
 
Em Access é definido o servidor que servirá de teste ao site e temos duas possibilidades: 
 
Local/Network (local) 
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Para a possibilidade de se testar o site no local (no nosso PC) é importante salientar que deverá 
existir a instalação de um servidor no nosso computador. No caso da linguagem de programação 
PHP um servidor Apache (www.apache.org), no caso de ASP o IIS já incluído no Windows, 
bastando instalar/activar o mesmo. 
 
Em Testing server folder é informado a pasta que servirá de teste local e em URL prefix, o 
endereço do servidor local por exemplo http://localhost/siteremoto/ (ou ainda 
http://127.0.0.1/siteremoto) que será o URL de teste no browser. 
 
FTP 
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No caso de pretendermos testar directamente no servidor remoto, seleccionamos FTP em Access, e 
tal como na configuração do FTP para publicação do site preenche-se os dados do servidor. 
 
URL prefix será o endereço completo da página na Internet. 
 
 
20.8. Ligação a uma base de dados  
 
Para fazer a ligação de um site ou página a uma base de dados é importante que, tal como na 
configuração de um site para programação, esteja configurado o Testing Server na definição do 
site. 
 
Vamos continuar com a linguagem PHP e com uma base de dados MySQL embora a operação seja 
igual com qualquer tipo de linguagem ou base de dados SQL. 
 
Depois de criada a base de dados e respectivas tabelas na base de dados, propriamente dita, 
teremos de fazer a ligação da mesma à página. Iremos criar uma página de visualização, inserção 
e edição de dados ou registos. 
 
Ligação à base de dados 
 
Esta operação será igual para todas as páginas que utilizarão a base de dados. 
Para isso criamos uma página PHP (neste caso) ou noutra linguagem, e adicionamos um Recordset 
(ligação à basa de dados).  
 

No painel Insert divisória Application, accionamos o primeiro botão Recordset ( ). 
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Name: será o nome da ligação; 
 
Connection: accionamos o botão Define… para definir a base de dados: 
 

 
 
Na janela Connections fos Site clicamos em New. 
 

 
 

Connection Name: o nome da ligação a determinada base de dados; 
MySQL Server: localhost (genericamente); 
Username: username; 
Password: não é necessária; 
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Database: seleccionamos Select… 
 

 
 
Deveram estar na lista as bases de dados existentes. Seleccionamos a pretendida e OK. 
 
Na Janela MySQL Connection, antes de dar-mos Ok accionamos Test e uma vez que o 
Dreamweaver não tolera campos em baixo deverá exibir uma mensagem onde nos diz que não foi 
inserida a passord. 
 

 
 
Deveremos ignorar esta mensagem e accionamos OK.  
 

 
 
Deverá esta a ligação na janela Connections for Site. 
 
Agora a ligação já pode ser seleccionada em Connection e as tabelas em Table. 
 



 83

 
 

No código é inserido automaticamente a ligação com a seguinte linha: 
<?php require_once('file:///D|/Websites/DW/ase/Connections/connAB.php'); ?> 
 
20.8.1. Página de visualização de dados 
 

Para criação da página de exibição dos dados clicamos no botão Dynamic Table ( ). Criará uma 
tabela onde seram exibidos os dados. 
 

 
 
Recordset: nome da ligação 
Show: número de registos que será mostrado por cada página. No caso de seleccionar-mos All 
records serão mostrados todos os registos na mesma página. 
Os três campos abaixo, Border, Cell padding e Cell spacing são respeitantes às dimnsões dos 
limotes d tabela. 
 
A tabela deverá ter mais ou menos este aspecto: 
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Os nomes da primeira linha representam as referências dos valores e poderão ser alterados. Na 
linha inferior serão mostrados os valores da base de dados. 
 
Todas as fontes e tamanhos de texto podem ser editados. 
 
Agora podemos inserir elementos de navegação entre os registos. Para isso clicamos em Recordset 

Paging ( ). 

 
 
Dysplay using: Text aplicará links em formato de texto, no caso de images irá inserir na página 
imagens que farão a navegabilidade (primeira, anterior, próxima e última). 
 

 
Tal como na tabela de exibição de dados também se pode modificar o tipo e tamanho da letra. 
 
Por sim poderemos adicionar a informação do número de registos existente. Clicamos no botão 

Display Record Count ( ). 
 

 
 

 
 
Claro que todas as expressões em inglês poderam ser alteradas para português excepto as que 
estiverem sinalizadas com a cor azul que são respeitantes aos dados. 
 
20.8.2. Página de inserção de dados 
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Como já referi atrás é necessário fazer a ligação à base de dados em todas as páginas. 

 

 

De seguida no ícone Insert Record ( ), expandimos as 
suas opções e seleccionamos Record Insertion Form. 
 

 

 
 

Connection: deveremos escolher a ligação criada; 
Table: a tabela na qual queremos inserir os dados; 
After inserting, goto: a página para a qual deverá o utilizador ser redireccionado quando accionar o 
botão de submit ou de confirmação (por exemplo a página de confimação). 
 
Deverá ficar como a imagem que se segue: 
 

 
Alteramos os textos e tipo de letra e a página está pronta. 
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20.8.3. Página de edição de dados 
 
Para a criação de uma página de edição de dados (alteração), e após termos feito uma ligação à 

base de dados, clicamos no botão Record Update Form Wizard ( ). 
 

 
 
Em Connection escolhemos a conecção (criada anteriormente) e em Table to update a base de 
dados a ser editada. 
 
No campo After updating, go to colocamos a página de confirmação para os dados inseridos. 
 
No campo Form fields inserimos ou retiramos campos, para que fiquem disponíveis apenas os 
pretendidos. 
 
O formulário deverá ter, mais ou menos, o seguinte aspecto: 
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Agora basta modificar o estilo de letra, cores, etc.. 
 
 
21. Trabalho em equipa 
 
 
21.1. WebDAV 
 
O WebDAV (Web-based Distribucted Authoring and Versioning) é um protocolo de internet que 
permite aos webdesigners e programadores de internet trabalharem em equipa pela própria rede 
de Internet em diferentes partes do mundo. 
 
O WebDAV permite a entrada de Login e password para um trabalho em grupo num conjunto de 
arquivos comuns. 
 
A configuração deste protocolo é feita em Remote Info na configuração do site. Menu Site > Edit 
Sites… (versão 6) ou menu Site > Manage Sites (versão 2004). 
 

 
 
Em Access escolhe-se WebDAV e clicamos Settings… Todos os elementos acerca da ligação deverão 
ser fornecidas. 
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Este sistema funciona em servidores Apache e IIS. 
 
 
21.2. Contribute (visão geral) 
 
Mais do que uma ferramenta de trabalho em equipa o Contribute é um excelente gerenciador 
online de páginas para o simples utilizador que não percebe nada de webdesigner.  
 
O Contribute, actualmente na versão 2, é um programa da Macromedia independente do 
Dreamweaver, e que por isso pode ser instalado com ou sem o Dreaweaver. 
 
O Contribute é das melhores maneiras para publicar, editar e actualizar sites online. As principais 
vantagens deste programa são: 
 
01. Criar conteúdo para o site de forma fácil, podendo inserir documentos do Word e Excel apenas 
com o clique do mouse, retirar e mudar as imagens do site, ou adicionar conteúdo; 
02. Publicar os sites e ver o resultado final com o brownser interno do próprio programa; 
03. Administração completa do site, tornando-se facilmente administrador; 
04. Integração com o Fireworks para edição de imagens com o Dreamweaver. 
 

 
 
Para interagir com o Dreamweaver vamos à configuração do site e na categoria Contribute 
colocamos o visto em Enable Contribute Compatibility. 
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